Note: The other languages of the website are Google-translated. Back to English
English English

Comment compter le nombre de cellules avec des valeurs différentes de zéro dans Excel?

Pour compter le nombre total de cellules avec des valeurs différentes de zéro dans Excel, nous allons vous montrer ici deux méthodes. Veuillez parcourir pour plus de détails.

Compter le nombre de cellules avec des valeurs différentes de zéro avec la formule
Compter le nombre de cellules avec des valeurs différentes de zéro avec Kutools for Excel


Compter le nombre de cellules avec des valeurs différentes de zéro avec la formule

Supposons que vous ayez une plage de données comme ci-dessous. Pour compter le nombre de cellules avec des valeurs différentes de zéro, procédez comme suit.

1. Sélectionnez une cellule vide pour localiser le résultat du comptage (ici je sélectionne la cellule H1). Copier et coller la formule = COUNTIF (A1: E8, "<> 0") into the Barre de formule, puis appuyez sur Entrer clé. Voir la capture d'écran:

2. Ensuite, le nombre total de valeurs différentes de zéro de la plage sélectionnée est compté et affiché dans la cellule H1.

Notes:

1. Avec la formule ci-dessus, vous pouvez compter les cellules non nulles qui incluent les cellules vides. Si vous souhaitez ignorer à la fois les cellules zéro et les cellules vides, veuillez appliquer cette formule: =COUNTA(A1:D10)-COUNTIF(A1:D10,"=0"), puis appuyez Entrer clé pour obtenir le résultat, voir capture d'écran:

2. Avec les formules ci-dessus, vous pouvez compter le nombre total de cellules avec des valeurs différentes de zéro dans une ligne, une colonne ou une plage dans Excel en modifiant les références de cellule dans la formule.


Compter le nombre de cellules avec des valeurs différentes de zéro avec Kutools for Excel

Outre les formules, le Sélectionnez des cellules spécifiques utilité de Kutools pour Excel peut vous aider à compter rapidement le nombre de cellules avec des valeurs différentes de zéro dans Excel.

Avant d'appliquer Kutools pour Excel, S'il vous plaît téléchargez et installez-le d'abord.

1. Sélectionnez la plage dans laquelle vous souhaitez compter le nombre de cellules non nulles. Puis clique Kutools > Sélectionnez > Sélectionnez des cellules spécifiques. Voir la capture d'écran:

2. Dans le pop-up Sélectionnez des cellules spécifiques boîte de dialogue, sélectionnez Cellule dans le Type de sélection section, précisez N'est pas égal dans le Type spécifique liste déroulante et entrez le numéro 0 dans la boîte vide. Cliquez enfin sur le OK bouton. Voir la capture d'écran:

3. Ensuite, une boîte de dialogue apparaît pour vous indiquer le nombre de cellules de valeur différente de zéro existant dans la plage sélectionnée. Et il a déjà exclu directement les cellules vides. Clique le OK bouton, ces cellules sont sélectionnées immédiatement.

  Si vous souhaitez bénéficier d'un essai gratuit (30 jours) de cet utilitaire, veuillez cliquer pour le télécharger, puis passez à appliquer l'opération selon les étapes ci-dessus.


Les meilleurs outils de productivité de bureau

Kutools for Excel résout la plupart de vos problèmes et augmente votre productivité de 80%

  • Réutilisation: Insérer rapidement formules complexes, graphiques et tout ce que vous avez utilisé auparavant; Crypter les cellules avec mot de passe; Créer une liste de diffusion et envoyer des e-mails ...
  • Barre Super Formula (modifiez facilement plusieurs lignes de texte et de formule); Disposition de lecture (lire et modifier facilement un grand nombre de cellules); Coller dans la plage filtréeplus
  • Fusionner les cellules / lignes / colonnes sans perdre de données; Contenu des cellules divisées; Combiner des lignes / colonnes en double... Empêcher les cellules en double; Comparer les gammesplus
  • Sélectionnez Dupliquer ou Unique Lignes; Sélectionnez les lignes vides (toutes les cellules sont vides); Super Find et Fuzzy Find dans de nombreux classeurs; Sélection aléatoire ...
  • Copie exacte Plusieurs cellules sans changer la référence de formule; Créer automatiquement des références à plusieurs feuilles; Insérer des puces, Cases à cocher et plus encore ...
  • Extrait du texte, Ajouter du texte, Supprimer par position, Supprimer l'espace; Créer et imprimer des sous-totaux de pagination; Conversion entre le contenu et les commentaires des cellulesplus
  • Super filtre (enregistrer et appliquer des schémas de filtrage à d'autres feuilles); Tri avancé par mois / semaine / jour, fréquence et plus; Filtre spécial par gras, italique ...
  • Combiner des classeurs et des feuilles de travail; Fusionner les tableaux en fonction des colonnes clés; Diviser les données en plusieurs feuilles; Conversion par lots xls, xlsx et PDFplus
  • Plus de 300 fonctionnalités puissantes. Prend en charge Office / Excel 2007-2019 et 365. Prend en charge toutes les langues. Déploiement facile dans votre entreprise ou organisation. Essai gratuit de 30 jours. Garantie de remboursement de 60 jours.
onglet kte 201905

Office Tab apporte une interface à onglets à Office et simplifie considérablement votre travail

  • Activer l'édition et la lecture par onglets dans Word, Excel, PowerPoint, Publisher, Access, Visio et Project.
  • Ouvrez et créez plusieurs documents dans de nouveaux onglets de la même fenêtre, plutôt que dans de nouvelles fenêtres.
  • Augmente votre productivité de 50% et réduit des centaines de clics de souris chaque jour!
bas de cabine
Commentaires (5)
Pas encore de notes. Soyez le premier à évaluer!
Ce commentaire a été minimisé par le modérateur sur le site
Q.Comment compter les cellules non nulles.
Rép. =NB.SI(F26:Q26,">0")
Ce commentaire a été minimisé par le modérateur sur le site
Merci pour vos efforts
Ce commentaire a été minimisé par le modérateur sur le site
=CONT.SE(AL27:AL31;">0")
Ce commentaire a été minimisé par le modérateur sur le site
MERCI POUR VOS INFORMATIONS
Ce commentaire a été minimisé par le modérateur sur le site
BRILLANT ..cherché 4 heures pour cela et tous les autres experts m'ont donné les formules les plus compliquées qui n'ont jamais fonctionné.formule : =COUNTA(A1:D10)-COUNTIF(A1:D10,"=0")

Merci
Il n'y a pas encore de commentaires postés ici
Laisser vos commentaires
Publier en tant qu'invité
×
Évaluez cet article:
0   Personnages
Emplacements suggérés