Passer au contenu principal

Maîtrise COUNTIF : 8 exemples Excel essentiels que vous devez connaître

Auteur : Soleil Dernière modification: 2023-08-17

Dans le travail quotidien, compter les occurrences de critères spécifiques dans un grand ensemble de données Excel peut donner l'impression de chercher une aiguille dans une botte de foin. Mais ne vous inquiétez pas, la fonction NB.SI d'Excel est là pour vous secourir. La fonction NB.SI est un outil puissant qui vous permet de compter rapidement et avec précision le nombre de points de données répondant à des critères spécifiques. Dans cet article, nous nous penchons sur la syntaxe et l'utilisation de la fonction NB.SI, en fournissant huit exemples pour vous aider à exploiter tout le potentiel de cette puissante fonction d'analyse.


Fonction NB.SI : syntaxe et arguments

 

La fonction NB.SI est utilisée pour compter le nombre de cellules dans une plage qui remplissent une condition.

Syntaxe

La syntaxe générique de COUNTIF ressemble à ceci :

=COUNTIF(range, criteria)

Arguments

  • Catégorie: Requis. Il s'agit de la plage dans laquelle vous souhaitez compter les critères spécifiques.
  • Critères: Requis. Cela définit ce que vous recherchez dans la plage définie.

Un exemple simple pour comprendre la fonction NB.SI

Pour rechercher un nom "Judy" dans une plage A4:A13 et compter, vous devez utiliser la fonction NB.SI comme ci-dessous :

=COUNTIF(A4:A13,"Judy")

Puis appuyez Entrer clé pour obtenir le compte.

doc countif exemple 1

Nous énumérons ici sept scénarios ci-dessous pour vous permettre de mieux comprendre comment utiliser la fonction NB.SI.


COUNTIF utilisations de base

 

Compter si les cellules avec un texte spécifique (correspondance exacte)

La fonction NB.SI peut être utilisée pour compter les cellules qui sont égales à un nombre, un texte ou une date spécifique.

Ici, nous prenons le tableau A3:C13 comme exemple, la colonne A contient des noms de fruits, la colonne B contient des nombres et la colonne C contient des dates. Nous compterons séparément les occurrences de "Apple", "100" et "6/10/2023" dans ces colonnes.

doc countif exemple 2 1

Le tableau ci-dessous fournit 3 scénarios différents basés sur l'exemple ci-dessus pour montrer comment écrire les critères dans la fonction NB.SI :

Target Critères Laits en poudre
Cellules égales à Apple "Apple" =NB.SI(A4:A13,"Pomme")
Cellules égales à 100 100 ou "100" =NB.SI(B4:B13,100)
Cellules égales au 6/10/2023 "6/10/2023" =COUNTIF(C4:C13,"6/10/2023")

Après avoir mis la fonction NB.SI, appuyez sur Entrer touche pour obtenir le résultat compté.

doc countif exemple 3 1

Notes:
  • Un ou plusieurs mots ou une date doivent être encadrés avec des quotas comme critères.
  • Au lieu de taper des critères, vous pouvez utiliser une référence à n'importe quelle cellule contenant les critères et obtenir les mêmes résultats, par exemple =COUNTIF(C4:C13,E6).

Envie d'un moyen simple de compter, sélectionner et mettre en surbrillance des cellules correspondant à un texte spécifique ? Kutools for Excel a la réponse avec son Sélectionnez des cellules spécifiques fonctionnalité! Faites l'expérience de sa puissance et de sa simplicité en téléchargez Kutools pour Excel et commencez votre essai gratuit de 30 jours dès aujourd'hui.

doc countif exemple 4 1


Compter si les cellules contiennent du texte spécifique (correspondance partielle)

Si vous souhaitez compter les cellules contenant des textes spécifiques, la fonction NB.SI peut également vous aider en utilisant des caractères génériques.

Caractères génériques :

  • Un point d'interrogation (?) correspond à n'importe quel caractère, par exemple, L??? trouve "Lisa" et "Lucy".
  • Un astérisque (*) correspond à zéro ou plusieurs caractères de n'importe quel type, par exemple, *cy trouve "Lucy" et "Nancy".
  • Le tilde (~) est le caractère "d'échappement", le plaçant avant un caractère générique (tel que ~*,~?,~*), le caractère générique est alors traité comme un caractère normal, par exemple, ~* trouve "*".

Dans cette section, nous prendrons comme exemple le comptage des occurrences du texte commençant par "L" dans la colonne A3:A13.

doc countif exemple 5

Et ici, nous présentons une liste de scénarios courants que vous pouvez rencontrer en fonction de l'instance, ainsi que les critères correspondants qui doivent être utilisés dans la fonction NB.SI, ainsi que les formules requises.

Target Critères Laits en poudre
Les cellules commencent par L "L*" =NB.SI(A4:A13,"L*")
Les cellules commencent par L et se terminent par 3 caractères "L ???" =NB.SI(A4:A13,"L???")
Les cellules se terminent par cy "*cy" =NB.SI(A4:A13,"*cy")
Les cellules commencent par 3 caractères et se terminent par y "???y" =NB.SI(A4:A13,"???y")
Les cellules te contiennent "*tu*" =NB.SI(A4:A13,"*u*")
Cellules égales à * "~*" =NB.SI(A4:A13,"~*")

Après avoir mis la fonction NB.SI, appuyez sur Entrer touche pour obtenir le résultat compté.

doc countif exemple 6

Notes: Au lieu de taper des critères, vous pouvez utiliser une référence à n'importe quelle cellule contenant les critères et obtenir les mêmes résultats, par exemple =COUNTIF(A4:A13,C4).

Vous cherchez à éclairer les cellules Excel contenant un texte spécifique ? Kutools for Excel est votre arme secrète ! Le Sélectionnez des cellules spécifiques fonctionnalité fera le travail en un rien de temps. Goûtez à l'efficacité en en téléchargeant Kutools for Excel - démarrez votre essai gratuit de 30 jours et regardez votre productivité monter en flèche !

doc countif exemple 7


Compter si les cellules ne sont pas vides ou vides

Si vous avez une large gamme de données et que vous avez besoin de compter efficacement le nombre de cellules vides ou non vides, la fonction NB.SI sera une aide précieuse.

Ici, nous utiliserons la plage A4:A11 comme exemple pour compter les cellules non vides et les cellules vides.

doc countif exemple 8

Target Critères Laits en poudre
Les cellules ne sont pas vides "<>" =COUNTIF(A4:A11,"<>")
Les cellules sont vides "" =COUNTIF(A4:A11,"")

Après avoir mis la fonction NB.SI, appuyez sur Entrer clé pour obtenir le résultat.

doc countif exemple 9 1

Prenez de l'avance dans Excel ! Avec Kutools for Excel's Sélectionnez les cellules non vides caractériser, compter et mettre en évidence les cellules non vides en un instant. Essayez Kutools maintenant avec un essai gratuit de 30 jours et augmentez votre productivité !

doc countif exemple 10


Compter si les cellules contiennent uniquement du texte ou des chiffres

Parfois, vous devrez peut-être compter les cellules contenant uniquement des chaînes de texte ou des nombres. Dans de tels cas, la fonction NB.SI peut s'avérer très utile.

Ici, nous utiliserons la plage A4: A11 comme exemple pour compter les cellules contenant uniquement du texte ou uniquement des nombres.

doc countif exemple 20

Target Critères Laits en poudre
Les cellules contiennent une chaîne de texte "*" =NB.SI(A4:A11,"*")
Les cellules ne contiennent que des nombres "<>"&"*" =NB.SI(A4:A11,"<>"&"*")

Après avoir mis la fonction NB.SI, appuyez sur Entrer clé pour obtenir le résultat.

doc countif exemple 21


Compter si les nombres sont supérieurs/inférieurs/égaux à

Pour compter les cellules avec des valeurs dans la plage A4: A13 supérieures, inférieures ou égales à un nombre spécifique, la fonction NB.SI peut également vous aider.

doc countif exemple 11

Vous pouvez simplement ajouter l'opérateur correspondant aux critères. Le tableau ci-dessous illustre les opérateurs que vous pouvez utiliser.

Target Critères Laits en poudre
Valeurs supérieures à 5 "> 5" =NB.SI(A4:A13,">5")
Valeurs inférieures à 5 "<5" =NB.SI(A4:A13,"<5")
Valeurs égales à 5 "=5" =NB.SI(A4:A13,"=5")
Valeurs non égales à 5 "<>5" =NB.SI(A4:A13,"<>5")
Valeurs supérieures ou égales à 5 ">=5" =NB.SI(A4:A13,">=5")
Valeurs inférieures ou égales à 5 "<=5" =NB.SI(A4:A13,"<=5")

Presse Entrer après avoir saisi la formule NB.SI.

doc countif exemple 12

Notes:
  • Il est important de noter que dans les formules COUNTIF, les opérateurs avec des nombres doivent toujours être placés entre guillemets.
  • Au lieu de taper des critères, vous pouvez utiliser une référence à n'importe quelle cellule contenant les critères et obtenir les mêmes résultats, par exemple =COUNTIF(A4:A13,C4), C4 contient le critère >5.

Compter si les dates sont supérieures/inférieures/égales à

Si vous devez compter des cellules avec des dates supérieures, inférieures ou égales à une date spécifique, vous pouvez utiliser des formules similaires à celles dont nous avons parlé précédemment. Les mêmes principes s'appliquent aux dates qu'aux nombres. Voici quelques exemples pour illustrer :

Target Critères Laits en poudre
Dates supérieures au 6/17/2023 ">6/17/2023"" =COUNTIF(A4:A13,">6/17/2023"))
Dates égales au 6/17/2023 "=6/17/2023" =COUNTIF(A4:A13,"=6/17/2023")
Dates inférieures ou égales au 6/17/2023 "<= 6/17/2023" =COUNTIF(A4:A13,"<=6/17/2023")

Presse Entrer clé pour obtenir le compte après avoir mis la formule COUNTIF.

doc countif exemple 13 1

En plus des utilisations courantes dont nous avons discuté, vous pouvez exploiter la fonction NB.SI en combinaison avec des fonctions de date et d'heure Excel spécifiques, telles que Fonction AUJOURD'HUI, pour compter les cellules en fonction de la date actuelle. Cela vous permet de suivre et de compter dynamiquement les cellules qui répondent aux critères de la date actuelle. Voici quelques exemples d'utilisation de la fonction NB.SI avec AUJOURD'HUI() :

Target Critères Laits en poudre
Dates supérieures à aujourd'hui ">"&AUJOURD'HUI() =NB.SI(A4:A13,">"&AUJOURD'HUI())
Dates égales à aujourd'hui "="&AUJOURD'HUI()) =NB.SI(A4:A13,"="&AUJOURD'HUI())
Dates dans moins d'une semaine à partir d'aujourd'hui ">"&AUJOURD'HUI()-7 =NB.SI(A4:A13,">"&AUJOURD'HUI()-7)

doc countif exemple 14


COUNTIF utilisations avancées

 

Compter si les cellules avec plusieurs critères (ou/et)

En effet, la fonction Excel NB.SI n'est pas spécialement conçue pour compter les cellules avec plusieurs critères. Dans de tels cas, la fonction recommandée est COUNTIFS fonction. Cependant, dans certaines situations, vous pouvez obtenir le résultat souhaité en combinant plusieurs fonctions NB.SI dans une même formule.

>> Ou critères

Supposons que vous souhaitiez compter les cellules égales à "Peach" ou "Apple", vous devez combiner deux fonctions COUNTIF ensemble comme indiqué ci-dessous :

=COUNTIF(A4:A11,"Peach")+COUNTIF(A4:A11,"Apple")

Presse Entrer clé pour obtenir le compte.

doc countif exemple 15

Notes: Au lieu de taper des critères, vous pouvez utiliser une référence à n'importe quelle cellule contenant les critères et obtenir les mêmes résultats, par exemple =COUNTIF(A4:A11,C4)+NB.SI(A4:A11,C5).

Veuillez noter que dans ce scénario, nous utilisons le signe plus (+) pour combiner les résultats obtenus à partir de deux fonctions NB.SI. De même, vous pouvez créer une formule COUNTIF avec plusieurs conditions en utilisant la même approche. Voici un exemple de formule COUNTIF avec trois conditions OR qui compte les occurrences de "Peach", "Apple" et "Lemon":

=COUNTIF(A2:A9,"Peach")+COUNTIF(A2:A9,"Apple")+COUNTIF(A2:A9,"Lemon")

>> Et critères

Supposons que vous souhaitiez compter les nombres supérieurs à 5 et inférieurs à 10 dans une plage A4: A11, vous pouvez combiner deux fonctions COUNTIF comme illustré ci-dessous :

=COUNTIF(A4:A11,">5")-COUNTIF(A4:A11,">=10")

Presse Entrer clé pour obtenir le compte.

doc countif exemple 16

Veuillez noter que dans ce scénario, nous utilisons le signe moins (-) pour combiner les résultats obtenus à partir de deux fonctions NB.SI.


Compter si les cellules sont des valeurs uniques ou en double

Si vous souhaitez compter des valeurs uniques ou des valeurs en double dans la plage A3: A13, la fonction NB.SI peut également vous aider.

Étape 1 : Identifiez si chaque valeur est unique ou en double
  1. Dans la colonne à côté des valeurs que vous souhaitez compter, utilisez la formule ci-dessous pour identifier la valeur associée est unique ou en double, VRAI indique que la valeur associée est en double, FAUX signifie que la valeur est unique.
    =COUNTIF($A$4:$A$13,A4)>1
  2. Presse Entrer et double-cliquez sur la poignée de remplissage (le petit carré vert dans le coin inférieur droit de la première cellule de résultat), puis tous les résultats sont affichés.

    remplir

Étape 2 : Comptez les valeurs uniques ou les valeurs en double
  • Pour compter les valeurs uniques, veuillez utiliser la formule ci-dessous
    =COUNTIF(B4:B13,"FALSE")
  • Pour compter les valeurs en double, veuillez utiliser la formule ci-dessous
    =COUNTIF(B4:B13,"TRUE")
    B4: B13 est la colonne d'aide que vous utilisez la formule à l'étape 1.
    Puis appuyez Entrer clé pour obtenir le résultat.
    doc countif exemple 18

Si vous préférez ne pas vous souvenir des formules, vous pouvez utiliser le Fonction Compter les valeurs uniques of Kutools for Excel. En seulement deux clics, vous pouvez obtenir le décompte dont vous avez besoin. De plus, Kutools for Excel propose une large gamme de formules qui vous permettent d'effectuer facilement et efficacement des calculs avancés.
Téléchargez Kutools for Excel et bénéficiez d'un essai gratuit de 30 jours

doc countif exemple 19


COUNTIF - notes et quelques problèmes importants

 
  • La fonction NB.SI n'est pas sensible à la casse.

  • La fonction COUNTIF nécessite une plage réelle, vous ne pouvez pas remplacer un tableau.

  • La fonction NB.SI ne prend pas en charge les plages non adjacentes et sa syntaxe ne permet pas de spécifier plusieurs cellules individuelles comme premier paramètre. Si vous souhaitez compter dans plusieurs plages, vous pouvez utiliser une combinaison de plusieurs fonctions NB.SI comme celle-ci :
    =COUNTSI(A2: A10,">0") + NB.SI(B3,">0") + NB.SI(C2: C5,">0").

  • La fonction NB.SI renvoie des résultats erronés lorsqu'elle est utilisée pour faire correspondre des chaînes de plus de 255 caractères.

  • La fonction NB.SI renvoie une erreur #VALUE lors du référencement d'un autre classeur fermé.

Meilleurs outils de productivité bureautique

🤖 Aide à l'IA Kutools: Révolutionner l'analyse des données en s'appuyant sur : Exécution intelligente   |  Générer du code  |  Créer des formules personnalisées  |  Analyser les données et générer des graphiques  |  Invoquer les fonctions Kutools...
Caractéristiques populaires: Rechercher, mettre en évidence ou identifier les doublons   |  Supprimer les lignes vides   |  Combinez des colonnes ou des cellules sans perdre de données   |   Tour sans formule 
Super recherche: VSearchup à critères multiples    VSearch à valeurs multiples  |   Recherche virtuelle sur plusieurs feuilles   |   Recherche floue ....
Liste déroulante avancée: Créez rapidement une liste déroulante   |  Liste déroulante dépendante   |  Liste déroulante à sélection multiple ....
Gestionnaire de colonnes: Ajouter un nombre spécifique de colonnes  |  Déplacer les colonnes  |  Basculer l'état de visibilité des colonnes masquées  |  Comparer les plages et les colonnes 
Caractéristiques en vedette: Mise au point de la grille   |  Voir Design   |   Grande barre de formule    Gestionnaire de classeurs et de feuilles   |  Ressources (Texte automatique)   |  Sélecteur de date   |  Combiner des feuilles de travail   |  Crypter/déchiffrer les cellules    Envoyer des e-mails par liste   |  Super filtre   |   Filtre spécial (filtre gras/italique/barré...) ...
Les 15 meilleurs ensembles d'outils12 Texte Outils (Ajouter du texte, Supprimer les caractères, ...)   |   50+ Graphique Types (Diagramme de Gantt, ...)   |   40+ Pratique Formules (Calculer l'âge en fonction de l'anniversaire, ...)   |   19 Insertion Outils (Insérer le code QR, Insérer une image à partir du chemin, ...)   |   12 Conversion Outils (Nombres en mots, Conversion des devises, ...)   |   7 Fusionner et fractionner Outils (Lignes de combinaison avancées, Cellules divisés, ...)   |   ... et plus

Améliorez vos compétences Excel avec Kutools for Excel et faites l'expérience d'une efficacité comme jamais auparavant. Kutools for Excel offre plus de 300 fonctionnalités avancées pour augmenter la productivité et gagner du temps.  Cliquez ici pour obtenir la fonctionnalité dont vous avez le plus besoin...

Description


Office Tab apporte une interface à onglets à Office et facilite grandement votre travail

  • Activer l'édition et la lecture par onglets dans Word, Excel, PowerPoint, Publisher, Access, Visio et Project.
  • Ouvrez et créez plusieurs documents dans de nouveaux onglets de la même fenêtre, plutôt que dans de nouvelles fenêtres.
  • Augmente votre productivité de 50% et réduit des centaines de clics de souris chaque jour!
Comments (0)
No ratings yet. Be the first to rate!
There are no comments posted here yet
Leave your comments
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations